
Grafy funkcí I - 2 D grafy

Vykreslení 2 D grafu

Funkce Plot ... Plot[funkce, {proměnná, od, do}]

Plot@Cos@xD, 8x, 0, 2 π<D
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Vykreslení grafů více funkcí v rámci jednoho grafu

Funkce Plot ... Plot[{funkce1,funkce2,...,funkceN}, {proměnná, od, do}]

Plot@8Sin@xD, Cos@xD<, 8x, 0, 2 π<D
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Vyjmenování jednotlivých funkcí lze uložit i do pomocné proměnné

f = 8Sin@xD, Sin@2 xD, Sin@3 xD<8Sin@xD, Sin@2 xD, Sin@3 xD<



Plot@f, 8x, 0, 2 π<D
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Vypsání parametrů funkce - příkaz Options

ü Options[Jmenofunkce] ... Výpis všech parametrů funkce

Options@PlotD:AlignmentPoint → Center, AspectRatio →
1

GoldenRatio
, Axes → True,

AxesLabel → None, AxesOrigin → Automatic, AxesStyle → 8<, Background → None,
BaselinePosition → Automatic, BaseStyle → 8<, ClippingStyle → None,
ColorFunction → Automatic, ColorFunctionScaling → True, ColorOutput → Automatic,
ContentSelectable → Automatic, CoordinatesToolOptions → Automatic,
DisplayFunction ¦ $DisplayFunction, Epilog → 8<, Evaluated → Automatic,
EvaluationMonitor → None, Exclusions → Automatic, ExclusionsStyle → None,
Filling → None, FillingStyle → Automatic, FormatType ¦ TraditionalForm, Frame → False,
FrameLabel → None, FrameStyle → 8<, FrameTicks → Automatic, FrameTicksStyle → 8<,
GridLines → None, GridLinesStyle → 8<, ImageMargins → 0., ImagePadding → All,
ImageSize → Automatic, ImageSizeRaw → Automatic, LabelStyle → 8<, MaxRecursion → Automatic,
Mesh → None, MeshFunctions → 8ð1 &<, MeshShading → None, MeshStyle → Automatic,
Method → Automatic, PerformanceGoal ¦ $PerformanceGoal, PlotLabel → None,
PlotPoints → Automatic, PlotRange → 8Full, Automatic<, PlotRangeClipping → True,
PlotRangePadding → Automatic, PlotRegion → Automatic, PlotStyle → Automatic,
PreserveImageOptions → Automatic, Prolog → 8<, RegionFunction → HTrue &L,
RotateLabel → True, Ticks → Automatic, TicksStyle → 8<, WorkingPrecision → MachinePrecision>

ü Options[Jménofunkce, Parametr] ... Výpis výchozího nastavení vybraného parametru

Options@Plot, FrameD8Frame → False<
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ü SetOptions[Jménofunkce, ParametrÆ Hodnota] ... Výpis výchozího nastavení vybraného parametru

SetOptions@Plot, Frame → TrueD:AlignmentPoint → Center, AspectRatio →
1

GoldenRatio
, Axes → True,

AxesLabel → None, AxesOrigin → Automatic, AxesStyle → 8<, Background → None,
BaselinePosition → Automatic, BaseStyle → 8<, ClippingStyle → None,
ColorFunction → Automatic, ColorFunctionScaling → True, ColorOutput → Automatic,
ContentSelectable → Automatic, CoordinatesToolOptions → Automatic,
DisplayFunction ¦ $DisplayFunction, Epilog → 8<, Evaluated → Automatic,
EvaluationMonitor → None, Exclusions → Automatic, ExclusionsStyle → None,
Filling → None, FillingStyle → Automatic, FormatType ¦ TraditionalForm, Frame → True,
FrameLabel → None, FrameStyle → 8<, FrameTicks → Automatic, FrameTicksStyle → 8<,
GridLines → None, GridLinesStyle → 8<, ImageMargins → 0., ImagePadding → All,
ImageSize → Automatic, ImageSizeRaw → Automatic, LabelStyle → 8<, MaxRecursion → Automatic,
Mesh → None, MeshFunctions → 8ð1 &<, MeshShading → None, MeshStyle → Automatic,
Method → Automatic, PerformanceGoal ¦ $PerformanceGoal, PlotLabel → None,
PlotPoints → Automatic, PlotRange → 8Full, Automatic<, PlotRangeClipping → True,
PlotRangePadding → Automatic, PlotRegion → Automatic, PlotStyle → Automatic,
PreserveImageOptions → Automatic, Prolog → 8<, RegionFunction → HTrue &L,
RotateLabel → True, Ticks → Automatic, TicksStyle → 8<, WorkingPrecision → MachinePrecision>

Plot@Cos@xD, 8x, 0, 2 π<D
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SetOptions@Plot, Frame −> FalseD:AlignmentPoint → Center, AspectRatio →
1

GoldenRatio
, Axes → True,

AxesLabel → None, AxesOrigin → Automatic, AxesStyle → 8<, Background → None,
BaselinePosition → Automatic, BaseStyle → 8<, ClippingStyle → None,
ColorFunction → Automatic, ColorFunctionScaling → True, ColorOutput → Automatic,
ContentSelectable → Automatic, CoordinatesToolOptions → Automatic,
DisplayFunction ¦ $DisplayFunction, Epilog → 8<, Evaluated → Automatic,
EvaluationMonitor → None, Exclusions → Automatic, ExclusionsStyle → None,
Filling → None, FillingStyle → Automatic, FormatType ¦ TraditionalForm, Frame → False,
FrameLabel → None, FrameStyle → 8<, FrameTicks → Automatic, FrameTicksStyle → 8<,
GridLines → None, GridLinesStyle → 8<, ImageMargins → 0., ImagePadding → All,
ImageSize → Automatic, ImageSizeRaw → Automatic, LabelStyle → 8<, MaxRecursion → Automatic,
Mesh → None, MeshFunctions → 8ð1 &<, MeshShading → None, MeshStyle → Automatic,
Method → Automatic, PerformanceGoal ¦ $PerformanceGoal, PlotLabel → None,
PlotPoints → Automatic, PlotRange → 8Full, Automatic<, PlotRangeClipping → True,
PlotRangePadding → Automatic, PlotRegion → Automatic, PlotStyle → Automatic,
PreserveImageOptions → Automatic, Prolog → 8<, RegionFunction → HTrue &L,
RotateLabel → True, Ticks → Automatic, TicksStyle → 8<, WorkingPrecision → MachinePrecision>

Plot@Cos@xD, 8x, 0, 2 π<D
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Parametry os grafu

ü Axes - parametr pro vykreslení os

Axes Ø  True ... Osy budou vykresleny

Axes Ø  False ... Osy nebudou vykresleny

Axes Ø  {True, False} ... Osa  X bude vykreslena, osa Y ne
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Plot@Cos@xD, 8x, 0, 2 π<, Axes → 8True, False<D
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ü AxesLabel - Popisky os grafu

AxesLabel Ø  None ... Osy budou vykresleny

AxesLabel Ø  label ... Popisek pro osu Y

AxesLabel Ø  {osaX, osaY} ... Popisky pro osu X a osu Y

Plot@Cos@xD, 8x, 0, 2 π<, AxesLabel → 8"X", "Y"<D
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ü AxesOrigin - Průsečík os X a Y

AxesOrigin Ø  Automatic ... Výchozí nastavení

AxesOrigin Ø  {x,y} ... Bod {x,y}
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Plot@Cos@xD, 8x, 0, 2 π<, AxesOrigin → 8π, 0<D
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ü Ticks - Zobrazení značek měřítka os

Ticks Ø  Automatic ... Výchozí nastavení

Ticks Ø  None... Bez značek

Ticks Ø  {{xticks1,xticks2,...},{yticks1,yticks2,...}} ... Zadání značek na specifické pozice

Ticks Ø  {{{xticks1,xlabel1},...},{{yticks1,ylabel1,},...}} ... Zadání značek se specifickými názvy na specifické pozice

Plot@Cos@xD, 8x, 0, 2 π<, Ticks → 880, π ê 2, π, 3 π ê 2, 2 π<, Automatic<D
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Plot@Cos@xD, 8x, 0, 2 π<, Ticks → 888π ê 2, "A"<, 83 π ê 2, "B"<<, Automatic<D
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ü AxesStyle - nastavení vzhledu os

AxesStyle -> style ... stejný styl pro všechny osy

AxesStyle -> {xstyle, ystyle} ... definice stylu pro jednotlivé osy

Za style se dosazují další parametry, např. Thickness {tloušťka}, RGBColor {barva}, Hue {odstín}, Dashing {čárkování}

Dashing, Thickness ... Tiny, Small, Medium, Large

RGBColor[red, green, blue] ... nastavení červené, zelené a modré barevné složky v intervalu 0 až 1

Hue[hue, saturation, brightness] ... Nastavení barvy pomocí modelu HSB (odstín, sytost, jas)

Plot@Cos@xD, 8x, 0, 2 π<,
AxesStyle → 88Dashing@LargeD, Thickness@LargeD, RGBColor@1, 0, 0D<, Automatic<D
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Plot@Cos@xD, 8x, 0, 2 π<, AxesStyle → 88Dashing@TinyD, Thickness@LargeD, Hue@1D<, Automatic<D
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Plot@Cos@xD, 8x, 0, 2 π<, AxesStyle → 88Dashing@LargeD, Thickness@LargeD, RGBColor@1, 0, 0D<,8Dashing@LargeD, Thickness@LargeD, RGBColor@0, 1, 0D<<D
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Parametry rámu grafu

ü Frame - orámování grafu

Frame Ø  True ... graf bude orámován

Frame Ø  False ... graf nebude orámován

Plot@Cos@xD, 8x, 0, 2 π<, Frame → TrueD
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ü FrameLabel - Pojmenování jednotlivých stran rámu

FrameLabel Ø  None ... rám grafu nebude pojmenován

FrameLabel Ø  {xmlabel,ymlabel} ... pojmenování levé a dolní části grafu

FrameLabel Ø  {xmlabel,ymlabel,xplabel,yplabel} ... pojmenování levé, dolní,pravé a horní části rámu
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Plot@Cos@xD, 8x, 0, 2 π<, Frame → True, FrameLabel → 8"X", "Y"<D
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ü FrameStyle - Nastavení stylu rámu grafu

FrameStyle -> Style ... nastavení stylu pro celý rám

FrameStyle -> {xmstyle, ymstyle, xpstyle, ypstyle} ... nastavení stylu levé, dolní, pravé a horní části rámu

Parametry stylu stejné jaku u AxesStyle

Plot@Cos@xD, 8x, 0, 2 π<, Frame → True, FrameLabel → 8"X", "Y"<, FrameStyle → Hue@1DD
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Plot@Cos@xD, 8x, 0, 2 π<, Frame → True, FrameLabel → 8"X", "Y"<, FrameStyle →88Dashing@TinyD, Thickness@LargeD, Hue@1D<, 8Dashing@TinyD, Thickness@LargeD, Hue@1D<,8Dashing@TinyD, Thickness@LargeD, Hue@1D<, 8Dashing@TinyD, Thickness@LargeD, Hue@1D<<D
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Text v grafu

ü PlotLabel - Pojmenování grafu

PlotLabel -> None ... bez pojmenování

PlotLabel -> "Text" ... text pojmenování

Plot@Cos@xD, 8x, 0, 2 π<, PlotLabel → "Funkce cosHxL"D
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Funkce cosHxL

ü BaseStyle - Nastavení písma celého grafu

BaseStyle -> {"style"} ... nastavení styl písma. Název dle menu Format -> Style

BaseStyle -> {opt1Ø val1,...} ... nastavení formátu písma, možnost použití FontFamily (font),FontSize (velikost),FontWeight
(tloušťka),FontColor (barva),FontSlant (tvar)

Pozn. V aplikaci Mathematica 6 a starší nutné použít vlastnost TextStyle

Plot@Cos@xD, 8x, 0, 2 π<, PlotLabel → "Funkce cosHxL",
BaseStyle → 8FontSize → 25, FontColor → Orange<D
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Funkce cosHxL
ü Style - Nastavení stylu vybraného textu

Style[expr, "style"] ... nastavení styl písma.Název dle menu Format -> Style
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Style[expr, opt -> val, ...] ... nastavení formátu písma, možnost použití FontFamily (font), FontSize (velikost), FontWeight
(tloušťka), FontColor (barva), FontSlant (tvar)

Pozn. V aplikaci Mathematica 6 a starší nutné použít vlastnost StyleForm

Style@Sqrt@Sin@xD ê xD, FontColor → RedD
Sin@xD

x

Parametry celkového vzhledu grafu

ü AspectRatio - nastavení poměru výška/šířka

AspectRatio -> 1/GoldenRatio ... výchozí nastavení pro 2 D

AspectRatio -> Automatic ... výchozí nastavení pro 3 D

AspectRatio -> hodnota/hodnota ... nastavení libovolného poměru

Plot@Cos@xD, 8x, 0, 2 π<, AspectRatio → 1 ê 1D
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ü GridLines - vytvoření mřížky

GridLines -> None ... bez mřížky

GridLines -> Automatic ... výchozí nastavení mřížky

GridLines -> {{x1,x2,x3,...},{y1,y2,y3,...}} ... definice mřížky pro x i y

GridLines -> {{x1,x2,x3,...},Automatic} ... definice mřížky pouze pro x

GridLines ->{{{x1,style},{x2,style},...},{y1,style},{y2,style},...}} ... definice mřížky se stylem

cviceni_3_2Dgrafy.nb  11



Plot@Cos@xD, 8x, 0, 2 π<, GridLines → 880, π ê 2, π, 3 π ê 2, 2 π<, 8−1, −0.5, 0, 0.5, 1<<D
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ü Background - nastavení pozadí grafu

Background -> None ... bez pozadí

Background -> Automatic ... výchozí pozadí pro daný sešit

Background -> barva ... možno použít funkce RGBColor, CMYKColor, GrayLevel nebo Hue

Plot@Cos@xD, 8x, 0, 2 π<, Background → GrayLevel@0.8DD
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ü PlotRange - meze pro jednotlivé osy

PlotRange -> All ... všechny body budou zahrnuty do grafu

PlotRange -> Automatic ... vzdálené body budou vynechány

PlotRange -> {min, max} ... limity osy y

PlotRange -> {{xmin, xmax}, {ymin, ymax}} ... limity os x a y
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Plot@Cos@xD, 8x, 0, 2 π<, PlotRange → 8−2, 2<D
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Parametry vykreslované grafu

ü PlotStyle - nastavení stylu křívky

PlotStyle -> style ... nastavení pro všechny křivky

PlotStyle -> {style1, style2, ...} ... nastavení více různých stylů pro jeden graf

PlotStyle -> {{style1}, {style2}, ...} ... nastavení pro jednotlivé křivky grafu

Za style se dosazují další parametry, např. Thickness {tloušťka}, RGBColor {barva}, Hue {odstín}, Dashing {čárkování}

Plot@Cos@xD, 8x, 0, 2 π<, PlotStyle → Thickness@LargeDD
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Plot@Cos@xD, 8x, 0, 2 π<, PlotStyle → 8Thickness@LargeD, RGBColor@1, 0, 0D<D
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Plot@8Sin@xD, Cos@xD<, 8x, 0, 2 π<, PlotStyle → 88RGBColor@0, 1, 0D<, 8RGBColor@1, 0, 0D<<D
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